Previously I have had some problems getting the DRAC 4/P (Dell Remote Access Card) working with Java 7 as it is only Java 6 compatible. Now Internet Explorer 11 (IE 11) was my next challenge, these four steps is how I got it to work:

1. Make sure you have a working  Java 6 runtime environment (JRE)

If not, follow the instructions in my previous post.

2. Add url to Compatability View List in IE

Click Tools icon (ALT+x) and select Compatability View settings and add the DRAC url.

(Without adding it here, when I click Open Console, it says Connecting… but then nothing happens, no error message, no nothing)

3. Add url to Exception Site List in Java Control Panel

Make sure you run the 32-bit version, e.g. c:\Program Files (x86)\Java\jre7\bin\javacpl.exe. Add it under the Security tab and click the Edit Site List button where you can add the DRAC url.

(Without adding it here, I would get a warning saying: Application Blocked by Security Settings, Name: VersionApplet, followed by an error message: Either you do not have a supported Java Virtual Machine (JVM) installed, or you did not accept the security credentials for the Console Redirect applet.)

4. Using IE, login to DRAC and click to open the Console

Accept warnings to Run an unsigned application and to let it use an older Java version.

Done!

I think IE11 does some sort of intelligent switching between 32 and 64 bit versions because I can now get it to work in any version, but if you have a problem make sure you run the 32-bit version of IE. As of IE11, there is only one IE icon in the Start menu, which is the 64-bit version, so go in to the file system and run C:\Program Files (x86)\Internet Explorer\iexplore.exe

Tested on Windows 7 64-bit with Microsoft Internet Explorer 11. DRAC 4/P firmware version 1.75 (Build 06.03).

It may be that you can skip any of the steps as it was a trial and error process to get this to work and I did not backtrack to find out if every step was absolutely necessary. To help others, please leave a comment if this worked or did not work for you and what version of software you were using.